Progressive slowdown with use

Dec 04, 2019
Sean Donnelly wrote
Good afternoon! After several months of use, I notice that while setting up slides Mediashout begins to progressively slowdown and take longer and longer to complete commands. For example, when I first open the program and apply a preset font format to some lyrics it works quickly, the second time it can take up to 10 seconds and the third time can be up to a minute. I checked the Task Manager and noticed at one point MS was using over 4 GB of memory and I was simply setting up slides without any graphics. If I save and shut down MS and restart it behaves again in the same fashion. This created an issue during worship when the program slowed to a slog and the sound team was unable to advance slides or even close the program.

Do you have any feedback on how to prevent this issue?

The computer we using is the one from your Premium computer bundle, purchased in October 2019.

Thank you for your assistance!

Sean Donnelly
Reply
7 Answers
Avatar image
Dec 05, 2019
Ben Wagner agent wrote
Hey Sean!

I'm sorry to hear that you're experiencing this. Just so I know we're on the same page, is this for MediaShout 6 or MediaShout 7?
Dec 05, 2019
Sean Donnelly wrote
It is MediaShout 7.2. Thanks!

Sean
Avatar image
Dec 05, 2019
Ben Wagner agent wrote
Thanks Sean!

What we're finding is relating to the "Cues Library". We have seen that when the Cues Library is exceptionally large, or includes a lot of cues with the video/motion backgrounds it is known to cause the program to get weighed down quite a bit and can cause issues with slowness and some freezing here or there. We are currently aware of some of these issues you're bringing up, and completely understand that it should be working regardless of if there are videos in that cues library. As of right now, since they are not we are heavily recommending saving the cues to the cues library without any videos attached. At that point you can just as easily click and drop simply from the file explorer or even just the desktop, and give the cue a background, whatever that may be.

That's our best thinking on it so far, but be aware we are working on and informing the developers of these slowness issues, and hope to have them corrected soon!

Let me know if you have further questions! God bless.
Dec 05, 2019
Sean Donnelly wrote
Hey, Ben! I really appreciate your thoughtful feedback. In my case, the "Cues Library" only has 25 (twenty-five) items, none of which have a video/motion element. Some have a static picture background but some are still the standard black. I look forward to your dev team presenting their creative and elegant solution soon!

Sean
Avatar image
Dec 06, 2019
Ben Wagner agent wrote
Hey Sean,

I see where you're coming from! Actually between my last response and now, the developers released a new build of the program, that has shown dramatic increase in the speed of the presets loading up, as well as drastic speed increases with the program all around.

Try downloading it from www.mediashout.com/download, and I think that should help a lot!

-Ben
Dec 06, 2019
Sean Donnelly wrote
Hey, Ben - It sure did, the presets are applying very fast with no slow down. I would consider my problem resolved at this point.
Just an FYI for you and the team, though. I checked the Task Manager throughout testing the presets and noticed that, even with no backgrounds at all, MediaShout was taking 1.3 GB of memory after apply a preset to 9 units, up from 500MB when I first opened the program. This memory was not released even after I closed that particular set of slides (via "File" -> "Close"). I'm not worried about it on my side, but I just wanted to pass it as I thought it was interesting.

Have a great day, and thank you for your help!

Sean
Avatar image
Dec 06, 2019
Ben Wagner agent wrote
Excellent!

Thanks so much Sean!